Monday, September 9, 2013

Blogger Error: You have logged out from another location...

A couple of hours ago, I was hit by the infamous "You have logged out from another location. Do you want to log in again?" error on Blogger, which, as it turned out, has been known since at least September 2012 (see this "known issue").



Right now, I have no time to dig deeper in order to understand
  • what exactly causes this eror;
  • why it happened today (even though I have not updated my browsers and have not changed any of their settings recently);
  • why it seems to happen with some browsers, but not with others (even though settings are generally the same), etc.


So, for now, I am just giving you a quick and dirty work-around:
  1. Log on to your Google account (it doesn't matter how: you can log on to GMail and then open Blogger or you can log on to Blogger directly).
  2. When you see the dreaded error message, go to your browser settings and allow third-party cookies.
  3. Refresh the Blogger page, and the error message should go away.
  4. Go back to your browser settings and disallow third-party cookies (this is optional, of course, but I would do it if I were you because by allowing third-party cookies you may compromise your privacy). From this point on, it should work fine until you log out.



UPDATE (and an EASIER FIX):

I have just noticed that, if you are not logged in to your Google account and go to blogger.com or www.blogger.com, you get redirected to https://accounts.google.com/ServiceLogin?service=blogger...., but, once you are logged in and redirected to Blogger, it throws you back to http (not https). Technically, you are logged in, but, if you click on any link on the dashboard, it gives you the error message. If now you simply change http to https in the URL box at the top of your browser and refresh the page, the error message will go away.

So,
  • if you are not logged in to your Google account and want to access Blogger directly, go to https://www.blogger.com instead of http; this will take you to the Google Account log on page and then redirect to https://www.blogger.com/....;
  • if you are already logged in to your Google account through some other service (say, Google+ or GMail), simply go to https://www.blogger.com.


Still, I cannot explain why this started happening to me today and why on some browsers Blogger works via http while on others - doesn't. With my IE 9.0.19 and Safari 5.1.7 for Windows, it works via http, but others have reported that it doesn't work for them on any browser. On the other hand, there are so many variables with different browser settings that figuring it out probably isn't worth the effort. Just use https, which appears to be a "universal fix".

25 comments:

Anonymous said...

Thank You!

Ira Portman said...

You are most welcome.

Steve said...

This worked for me...thank you! (And after more than a year, Google still hasn't fixed this)

Ira Portman said...

You are welcome, Steve!
As you can see, the "known issue" entry was last updated on the day it was created. So, looks like nobody has ever even bothered to look into it. I guess, you get what you pay for... if you're lucky :-P
Luckily for us, there is an easy workaround.

ASC said...

Thanks for this quick fix :)

Ira Portman said...

No problem, ASC!

Dave Thome said...

This seems to be working. TY.

Ira Portman said...

YRW, Dave.

Miyaka said...

Hi! I've had the same problem for a couple days as well and this solved my problem of viewing my posts/stats/etc. However, I'm now getting this message: http://i41.tinypic.com/21ky1bm.jpg when I try to post pictures. Even after I sign in, I get this: http://i44.tinypic.com/2q3ukvl.jpg
I am using Chrome and have always used Chrome. Do you know how to fix this? Any help would be greatly appreciated! Thanks!

Anonymous said...

Thank you for help. It worked! Though I have been tryings several ways to get overfor tehpast few days.I think the problem is something to do with Firefox browser. I logged in through Internet Exploer and there was no problm.

Anonymous said...

I have solved the problem by another simple way after going through your method If you have bookmarked the your blog, right click on it and go to the properties. In the the location details, add 's' to 'http' in url line and save.It is working well.
R

Ira Portman said...
This comment has been removed by the author.
MrsEvilGenius said...

Thank you! Thank you! *SMOOCHES!*

Jenn said...

Much appreciated! Worked the first time.

Ira Portman said...

You are more than welcome, MrsEvilGenius and Jenn!

Ira Portman said...

Hi, Miyaka,

At first I could not reproduce the bug you had reported, but less than two days later I started experincing the same problems while I wasn't even trying to reproduce "your bug".

If you are still experincing problems uploading/inserting images into blog posts, here is the answer: http://1stopit.blogspot.com/2013/09/another-blogger-bug-in-order-to-select.html

P.S. I am going to delete my previous reply to you not to confuse people looking for the fix.

Miyaka said...

Thank you so much!!! I used Workaround #2 and it worked for me right away!
Not sure if there's any sort of connection, but there were times when I was able to upload photos after commenting on other people's blog posts.

Ira Portman said...

Miyaka,
I am glad to have solved your problem with uploading and inserting images into blog posts on Blogger.

As to your observation that sometimes you were able to upload images after commenting on other people's blogs, I have to say that it was a very keen observation. BTW, how long were you able to do that? Until you logged out of Blogger? Just once after each comment?

Whether those two are connected is hard to tell without testing. It is certainly possible that they are. I may look into it when/if I have time, but you will have to let me post "test comments" on your blog :-)

Miyaka said...

There were two times where I noticed I was able to upload images after commenting on other people's blogs, and one time where I was not able to, for whatever reason. I did not log out of Blogger and try again to see if it would continue working if I logged back in though.

Feel free to leave test comments whenever you wish to test this out. However, I must add that I use the Disqus commenting form (on both of my blogs) as opposed to the one provided by Blogger. I'm not sure if commenting/uploading photos thing only works with Blogger/Google services.

Ira Portman said...

Thanks for the additional info. No, testing with Disqus doesn't make sense. It's OK. I'll figure something out when/if I decide to try to untangle this mess. Thanks again!

Admin said...

thank u bro

Admin said...

thank u bro

Ira Portman said...

You are welcome

Lisa Gunderson said...

I am having the same issue on all my blogger blogs all of a sudden today, and your tricks are not working for me. I have tried them all, and the error message continues to appear, and I can not update... I have cleared cache, allowed 3rd party, cleared cookies, tried Chrome and Firefox, used https, rebooted and so on.

Ira Portman said...

Lisa,
I am sorry to hear that. I tried to reproduce the problem, and I couldn't. As I was doing that, I even noticed that, to Google's credit, now, even if you go to blogger.com or www.blogger.com (without https), you still get redirected to https://www.blogger.com. So, the bug described in my post appears to have been fixed (finally), which unfortunately means that I don't know how to help you. Sorry!